UPDATE: On the Macintosh, this appears to be a Mac OS X 10.9 “Mavericks”-only bug. Apple has already confirmed a patch is in the works. In the meantime, if your Mac is running Mavericks we advise against conducting any internet transactions in which you would normally have an expectation of security (banking, shopping, etc.). Until this bug is patched, things that may look secure are not.

Apple has issued system updates for iOS 6 and iOS 7, the two operating systems for iPhone, iPad, and iPod touch that are impacted by a serious security flaw. iOS 5 and earlier systems are not compromised.

To update, go to Settings > General > Software Update.

Expect a similar security update for Macintosh operating systems very soon.

More details are available here: