Mac HelpMate 2.2

Mac HelpMate 2.2 – compatible with Mac OS X 10.3, 10.4 and 10.5